آبل تجبر التطبيقات أن تتوافق مع iOS 7

ios 7

قالت شركة آبل أن كل التطبيقات الجديدة و تحديثات التطبيقات التي سيتم إرسالها إلى متجر التطبيقات بعد الأول من فبراير القادم يجب أن تكون محسنة ومتوافقة مع نظام iOS 7 ومطورة على أحدث نسخة من حزمة تطبيقات تطوير التطبيقات Xcode 5.

وهذا التصرف ليس جديد على آبل حيث تجبر مطوريها أن يدفعوا بتطبيقاتهم إلى مستوى أنظمة التشغيل الجديدة وإتباع معايير التصميم والتوافقية.

وأتاحت الشركة المجال أمام المطورين للخيار فيما إذا كانوا يرغبون بإبقاء النسخ القديمة من تطبيقاتهم مثل المتوافقة مع iOS 6 أن تكون متاحة للتحميل أم لا.

لكن قيود متجر التطبيقات الجديدة تريد أن تدفع كل المطورين للإعتماد على أحدث نسخة من النظام و وقف دعم النسخة القديمة، وهي خطوة لدفع المستخدمين أيضاً لتحديث أنظمة أجهزتهم للحصول على أحدث التطبيقات والتحديثات.

المصدر

 

  • يزيد العلي

    دائما الافضل !

  • PAKREY

    خطوة ممتازة من أبل وينبغي على الشركات الأخرى أن تحذو حذوها بمن فيهم جوجل التي يفوق عدد مستخدميها مستخدمي IOS .

تعليقات عبر الفيسبوك